Notice
Recent Posts
Recent Comments
Link
«   2024/12   »
1 2 3 4 5 6 7
8 9 10 11 12 13 14
15 16 17 18 19 20 21
22 23 24 25 26 27 28
29 30 31
Archives
Today
Total
관리 메뉴

게임 개발 메모장

52. 인접행렬(가중치 방향그래프) 본문

문제 해결력 훈련

52. 인접행렬(가중치 방향그래프)

Dev_Moses 2024. 1. 18. 22:10

 

▣ 입력예제 

 

6 9

1 2 7

1 3 4

2 1 2

2 3 5

2 5 5

3 4 5

4 2 2

4 5 5

6 4 5

 

 

▣ 출력예제

 

0 7 4 0 0 0

2 0 5 0 5 0

0 0 0 5 0 0

0 2 0 0 5 0

0 0 0 0 0 0

0 0 0 5 0 0

 

#include <iostream>
#include <vector>
#include <algorithm>

using namespace std;

int map[21][21];

int main()
{
	int n,m,a,b,c;
	cin >> n >> m;

	for (int i = 1; i <= m; ++i)
	{
		cin >> a >> b >> c;
		map[a][b] = c;  // 가중치 그래프
		//map[b][a] = c;  // 무방향 그래프일 때는 이것까지
	}

	for (int i = 1; i <= n; ++i)
	{
		for (int j = 1; j <= n; ++j)
		{
			cout << map[i][j];
		}

		cout << endl;
	}
}

'문제 해결력 훈련' 카테고리의 다른 글

54. 최소비용(DFS : 인접행렬)  (0) 2024.01.18
53. 경로 탐색(DFS)  (0) 2024.01.18
51. 특정 수 만들기(DFS : MS 인터뷰)  (0) 2024.01.18
50. 부분 집합 (DFS)  (0) 2024.01.18
49. 합이 같은 부분집합(DFS)  (0) 2024.01.18